mplayer

Здесь обсуждаются все вопросы, не попадающие под другие категории
Аватара пользователя
luka
Интересующийся
Сообщения: 76
Зарегистрирован: 08 янв 2006, 16:51
Откуда: Deutschland, Hamburg
Контактная информация:

mplayer

Сообщение luka »

Доброго всем времени суток
На стареньком ibm 600e стоит xubutu 10.10
В качестве видеоплеера использую mplayer .
Проблемка вот в чем - припроигрывании некоторых видеофайлов .avi если в качестве videooutput оставить дефолтный xv то картинка пуста а звук есть. Если этот же файл включаю на x11 вместо xv , то и картинка и звук есть, но может подтормаживать , не совпадает звук с видео, и не разворачивается на весь экран.
Чем можно это исправить ?

Aleksey Kondratenko
Неотъемлемая часть форума
Сообщения: 250
Зарегистрирован: 12 авг 2003, 03:55
Контактная информация:

Re: mplayer

Сообщение Aleksey Kondratenko »

Попробуй -vo sdl

leave
Неотъемлемая часть форума
Сообщения: 1055
Зарегистрирован: 25 окт 2006, 14:50
Откуда: minsk
Контактная информация:

Re: mplayer

Сообщение leave »

А что xvinfo?

Аватара пользователя
luka
Интересующийся
Сообщения: 76
Зарегистрирован: 08 янв 2006, 16:51
Откуда: Deutschland, Hamburg
Контактная информация:

Re: mplayer

Сообщение luka »

с -vo sdl - черная картинка, звук есть.

xvinfo :
X-Video Extension version 2.2
screen #0
Adaptor #0: "NeoMagic Video Engine"
number of ports: 1
port base: 74
operations supported: PutVideo PutImage
supported visuals:
depth 8, visualID 0x23
depth 16, visualID 0x21
number of attributes: 3
"XV_COLORKEY" (range 0 to 16777215)
client settable attribute
client gettable attribute (current value is 2110)
"XV_BRIGHTNESS" (range -128 to 127)
client settable attribute
client gettable attribute (current value is 0)
"XV_INTERLACE" (range 0 to 2)
client settable attribute
client gettable attribute (current value is 0)
number of encodings: 1
encoding ID #0: "XV_VIDEO"
size: 1024 x 1024
rate: 1.000000
maximum XvImage size: 1024 x 1024
Number of image formats: 5
id: 0x32595559 (YUY2)
guid: 59555932-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x32315659 (YV12)
guid: 59563132-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
id: 0x30323449 (I420)
guid: 49343230-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
id: 0x35315652 (RV15)
guid: 52563135-0035-0000-0000-000000000000
bits per pixel: 16
number of planes: 1
type: RGB (packed)
depth: 15
red, green, blue masks: 0x1f, 0x3e0, 0x7c00
id: 0x36315652 (RV16)
guid: 52563136-0000-0000-0000-000000000000
bits per pixel: 16
number of planes: 1
type: RGB (packed)
depth: 16
red, green, blue masks: 0xf800, 0x7e0, 0x1f

Aleksey Kondratenko
Неотъемлемая часть форума
Сообщения: 250
Зарегистрирован: 12 авг 2003, 03:55
Контактная информация:

Re: mplayer

Сообщение Aleksey Kondratenko »

У тебя в дровах, походу, поломанный XVideo.

Попробуй -vo sdl:noforcexv

Имеет также смысл попробовать обновить дрова.

Аватара пользователя
luka
Интересующийся
Сообщения: 76
Зарегистрирован: 08 янв 2006, 16:51
Откуда: Deutschland, Hamburg
Контактная информация:

Re: mplayer

Сообщение luka »

хмм ... попробовал, все то же самое :(
Я xvideo не ломал , они наверное так изначально стали.
Чесно говоря я в обновлении дров немножко ламер :oops: . даже незнаю какой там чип стоит

leave
Неотъемлемая часть форума
Сообщения: 1055
Зарегистрирован: 25 окт 2006, 14:50
Откуда: minsk
Контактная информация:

Re: mplayer

Сообщение leave »

luka писал(а):даже незнаю какой там чип стоит
NeoMagic Video Engine :)

Аватара пользователя
Llama
Неотъемлемая часть форума
Сообщения: 9749
Зарегистрирован: 06 фев 2002, 11:40
Откуда: Менск

Re: mplayer

Сообщение Llama »

Насколько я помню, там драйвер не поддерживает ускорение xv, попробуйте -vo x11
Но вообще мне в своё время не удалось добиться на этом буке нормального восрпоизведения видео к сожалению.
Опыт растет прямо пропорционально выведенному из строя оборудованию

Аватара пользователя
luka
Интересующийся
Сообщения: 76
Зарегистрирован: 08 янв 2006, 16:51
Откуда: Deutschland, Hamburg
Контактная информация:

Re: mplayer

Сообщение luka »

Так дело то в том что некоторые ави-файлы воспроизводит замечательно через xv, а некоторые не хочет :( , какбы воспроизведение идет но картинка пуста а мплеер в это время ругается - X11 error: BadAlloc (insufficient resources for operation) .
Может дело в кодеке ?

leave
Неотъемлемая часть форума
Сообщения: 1055
Зарегистрирован: 25 окт 2006, 14:50
Откуда: minsk
Контактная информация:

Re: mplayer

Сообщение leave »

insufficient resources for operation
перевести? ;)

leave
Неотъемлемая часть форума
Сообщения: 1055
Зарегистрирован: 25 окт 2006, 14:50
Откуда: minsk
Контактная информация:

Re: mplayer

Сообщение leave »

Посмотрел я на этот ноут.

Код: Выделить всё

Neomagic MagicMedia256AV with 2.5MB
Intel Mobile Pentium II 300, 366 or 400 CPU
Xv здесь вообще удивительно, что работает. ИМХО или фреймбуффер, или -vo aa :)

Ответить