glibc - после некорректного обновления потеряны библиотеки

Форум предназначен для новичков. В нем предполагается рассматривать вопросы, которые встают на первых этапах освоения Linux
booxter
Неотъемлемая часть форума
Сообщения: 1427
Зарегистрирован: 04 апр 2004, 21:04

Сообщение booxter »

Гэта галоўная сістэмная бібліятэка, з якой лінкуюцца ўсе твае праграмы. Змяняеш версію glibc на кардынальна новую -> ламаеш ABI -> атрымліваеш непрацоўную сістэму.

dg333
Неотъемлемая часть форума
Сообщения: 293
Зарегистрирован: 10 май 2006, 09:46
Откуда: Менск

Сообщение dg333 »

(чэшучы ў патыліцы) Тады, можна сказаць, пашанцавала...
openSUSE 11.3/12.3

booxter
Неотъемлемая часть форума
Сообщения: 1427
Зарегистрирован: 04 апр 2004, 21:04

Сообщение booxter »

Цікава, для чаго гэтаму інсталятару новы glibc спатрэбіўся?:-/ Трэба было, мабыць, самому скампіляваць усё - прасцей выйшла б.

Аватара пользователя
myst
Маньяк
Сообщения: 190
Зарегистрирован: 04 окт 2005, 15:46
Откуда: не возвращаются

Сообщение myst »

в мемориз! :D
Иными вечерами я пью, чтобы кого-нибудь не пристрелить. Это акт благотворительности. Не за что.

dg333
Неотъемлемая часть форума
Сообщения: 293
Зарегистрирован: 10 май 2006, 09:46
Откуда: Менск

Сообщение dg333 »

booxter, калі я правільна разумею, гэны інсталятар і выклікае кампіляцыю. Але я ўжо ня ўпэўнены ні ў чым :-)
openSUSE 11.3/12.3

Аватара пользователя
mungo
Фанатеющий
Сообщения: 151
Зарегистрирован: 10 сен 2006, 10:32
Откуда: Минск
Контактная информация:

Re: glibc - после некорректного обновления потеряны библиоте

Сообщение mungo »

dg333 писал(а):openSUSE 10.2. Попытался установить glibc 2.6. Поскольку 2.6 не хотел ставиться поверх 2.5 и Yast2 ругался насчёт зависимостей по туче пакетов, сначала удалил 2.5, везде поставив галочку "игнорировать". Поставил 2.6, теперь часть программ не запускается. Например, при запуске Midnight Commander появляется:

Код: Выделить всё

/usr/bin/mc: error while loading shared libraries: libgmodule-2.0.so.0: cannot open shared object file: No such file or directory
Просматриваю структуру glibc-2.6-6.i586.rpm в Krusader - там такого файла не вижу. Пытался руками снова установить RPM из консоли, так не устанавливает, типа уже всё есть.

Самое печальное то, что теперь не запускается Yast2, не монтируются сменные носители, вообще мрак :-( Что делать?
Читаю и удивляюсь... Причем здесь глибц? libgmodule - Это ваще-то glib, гномья библиотека. А glibc - библиотека стандартных Си функций (типа работа с памятью, к примеру). Glib-2, гномья, это только враппер для более упрощенной работы с тем же глиб.
Сомневаюсь, и вам советую!

dg333
Неотъемлемая часть форума
Сообщения: 293
Зарегистрирован: 10 май 2006, 09:46
Откуда: Менск

Сообщение dg333 »

mungo, поскольку после принудительного возврата glibc 2.5 данная ошибка (и многие другие) пропали, значит, glibc явно при чём-то.

Аватара пользователя
Llama
Неотъемлемая часть форума
Сообщения: 9749
Зарегистрирован: 06 фев 2002, 11:40
Откуда: Менск

Сообщение Llama »

mungo, тем умникам которые придумали назвать практически одинково - glibc aka GNU libc и glib aka libglib надо сделать как минмум серьезное внушение - людей путають ;)
Опыт растет прямо пропорционально выведенному из строя оборудованию

Аватара пользователя
Mr. Anderson
Неотъемлемая часть форума
Сообщения: 373
Зарегистрирован: 10 окт 2005, 14:35

Сообщение Mr. Anderson »

booxter писал(а):dg333, чаму ў мяне на Gentoo добра ставіцца? Можа, Вы неяк няправільна гэта робіце?
+1 :D
так сорцы ж все-таки ;) а кто их, меэйнтейнеров пакетов этих, разберет? мало ли, что у них на уме ;)
поскольку после принудительного возврата glibc 2.5 данная ошибка (и многие другие) пропали, значит, glibc явно при чём-то.
glibc тут при динамической линковке
ем умникам которые придумали назвать практически одинково - glibc aka GNU libc и glib aka libglib надо сделать как минмум серьезное внушение - людей путають Wink
це точно ;)
LMD / DML

Ответить